Configuring the Application Settings

The Application Settings section enables you to configure the Masterworks user interface. You need to configure the following after the application is installed and before you make it available to users:

  1. Application name: Displayed as the title of the web browser in which the application is opened.
  2. Report logo: Displayed on every report generated in Masterworks.
  3. SMTP server and e-mail address: Send and receive application related e-mails.
  4. Application logging levels and mode: Define logging levels and storage of errors and warnings generated by the application.
Steps
  1. In the module menu, click Administration.

  2. Expand System Configurations, and then click Application Settings.
    The Application Settings page is displayed.
  3. Provide the required information in the fields, as described in the following table:

    Group Field Description
      Application Name Enter the name that should be displayed as the tab name of the browser when the application is opened in the browser.
    Blocked File Types Enter file extensions of file types that must be blocked from being uploaded into the application. Files of the specified file types are not uploaded to the application in the document management system, nor as attachments in any forms.
    Max allowable Document Size in Attachment (in MB) Enter the maximum size limit (in MB) of the attachment that are uploaded in the application forms.
    Mail Configurations Server Name Enter the SMTP server IP address to enable the application to send email notifications to the configured SMTP server.
    For example, outlook.<company>.com.
    Send Test Mail Click to send a test email to verify the configured application SMTP server address. An error message is displayed if the configured SMTP server does not exist.
    Server User Name Enter the SMTP server user name.
    Server Password Enter the password to secure SMTP server.
    Server Port Enter the SMTP server port number.
    Enable SSL Select the checkbox to enable SSL .
    Sender Email Id

    Enter the official email address from which notifications will be sent to users from the application.

    For example, admin@<company>.com

    Sender Name

    By default, the sender name is displayed as Administrator.

    If required, enter the name that is displayed as the name of the sender when the notifications will be sent to users from the application.

    Events Recipient Email ID

    The default email address is displayed as "administrator@aurigo.com".

    If required, enter the email address of the application administrator who is notified of the events in the application after the scheduled event is successfully executed or failed.

  4. Click Save.


© Aurigo Software Technologies Inc.